aboutsummaryrefslogtreecommitdiffstats
path: root/tests/auto/quick/qquickwindow/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/quick/qquickwindow/CMakeLists.txt')
-rw-r--r--tests/auto/quick/qquickwindow/CMakeLists.txt11
1 files changed, 2 insertions, 9 deletions
diff --git a/tests/auto/quick/qquickwindow/CMakeLists.txt b/tests/auto/quick/qquickwindow/CMakeLists.txt
index 390fa0c154..8d119952f7 100644
--- a/tests/auto/quick/qquickwindow/CMakeLists.txt
+++ b/tests/auto/quick/qquickwindow/CMakeLists.txt
@@ -5,15 +5,12 @@
#####################################################################
# Collect test data
-
-file(GLOB test_data_glob
- LIST_DIRECTORIES true
+file(GLOB_RECURSE test_data_glob
RELATIVE ${CMAKE_CURRENT_SOURCE_DIR}
- "data/*")
+ data/*)
list(APPEND test_data ${test_data_glob})
add_qt_test(tst_qquickwindow
- GUI
SOURCES
../../shared/util.cpp ../../shared/util.h
../shared/geometrytestutil.cpp ../shared/geometrytestutil.h
@@ -37,15 +34,11 @@ add_qt_test(tst_qquickwindow
)
#### Keys ignored in scope 1:.:.:qquickwindow.pro:<TRUE>:
-# CONFIG = "testcase"
# OTHER_FILES = "data/active.qml" "data/AnimationsWhileHidden.qml" "data/Headless.qml" "data/showHideAnimate.qml" "data/windoworder.qml" "data/grabContentItemToImage.qml"
## Scopes:
#####################################################################
-#### Keys ignored in scope 2:.:.:qquickwindow.pro:APPLE_OSX:
-# CONFIG = "-app_bundle"
-
extend_target(tst_qquickwindow CONDITION ANDROID OR APPLE_IOS
DEFINES
QT_QMLTEST_DATADIR=\\\":/data\\\"