aboutsummaryrefslogtreecommitdiffstats
path: root/tests/auto/quickcontrols2/controls/material/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/quickcontrols2/controls/material/CMakeLists.txt')
-rw-r--r--tests/auto/quickcontrols2/controls/material/CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/tests/auto/quickcontrols2/controls/material/CMakeLists.txt b/tests/auto/quickcontrols2/controls/material/CMakeLists.txt
index bc1846e52a..b07a63e32d 100644
--- a/tests/auto/quickcontrols2/controls/material/CMakeLists.txt
+++ b/tests/auto/quickcontrols2/controls/material/CMakeLists.txt
@@ -24,6 +24,17 @@ qt_internal_add_test(tst_material
TESTDATA ${test_data}
)
+# Make the QML files available to Creator's locator.
+target_sources(tst_material
+ PRIVATE
+ ${test_data}
+)
+
+set_source_files_properties(${test_data}
+ PROPERTIES
+ HEADER_FILE_ONLY ON
+)
+
#### Keys ignored in scope 1:.:.:material.pro:<TRUE>:
# OTHER_FILES = "$$PWD/../data/*.qml"
# TEMPLATE = "app"