aboutsummaryrefslogtreecommitdiffstats
path: root/tests/manual/quickcontrols2/dialogs/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/manual/quickcontrols2/dialogs/CMakeLists.txt')
-rw-r--r--tests/manual/quickcontrols2/dialogs/CMakeLists.txt32
1 files changed, 32 insertions, 0 deletions
diff --git a/tests/manual/quickcontrols2/dialogs/CMakeLists.txt b/tests/manual/quickcontrols2/dialogs/CMakeLists.txt
new file mode 100644
index 0000000000..cc132f36e4
--- /dev/null
+++ b/tests/manual/quickcontrols2/dialogs/CMakeLists.txt
@@ -0,0 +1,32 @@
+if (NOT QT_BUILD_STANDALONE_TESTS AND NOT QT_BUILDING_QT)
+ cmake_minimum_required(VERSION 3.16)
+ project(dialogs LANGUAGES C CXX ASM)
+ find_package(Qt6BuildInternals COMPONENTS STANDALONE_TEST)
+endif()
+
+qt_internal_add_manual_test(dialogs
+ GUI
+ SOURCES
+ dialogs.cpp
+ PUBLIC_LIBRARIES
+ Qt::Gui
+ Qt::Qml
+ Qt::QuickControls2
+)
+
+# Resources:
+set(qmake_immediate_resource_files
+ "dialogs.qml"
+ "FileDialogPage.qml"
+ "FontDialogPage.qml"
+ "StringListView.qml"
+ "qmldir"
+ "Theme.qml"
+)
+
+qt_internal_add_resource(dialogs "qmake_immediate"
+ PREFIX
+ "/"
+ FILES
+ ${qmake_immediate_resource_files}
+)