aboutsummaryrefslogtreecommitdiffstats
path: root/tests/manual/quickcontrols2/headerview/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/manual/quickcontrols2/headerview/CMakeLists.txt')
-rw-r--r--tests/manual/quickcontrols2/headerview/CMakeLists.txt54
1 files changed, 54 insertions, 0 deletions
diff --git a/tests/manual/quickcontrols2/headerview/CMakeLists.txt b/tests/manual/quickcontrols2/headerview/CMakeLists.txt
new file mode 100644
index 0000000000..4c4ae94a56
--- /dev/null
+++ b/tests/manual/quickcontrols2/headerview/CMakeLists.txt
@@ -0,0 +1,54 @@
+# Generated from headerview.pro.
+
+if (NOT QT_BUILD_STANDALONE_TESTS AND NOT QT_BUILDING_QT)
+ cmake_minimum_required(VERSION 3.16)
+ project(headerview LANGUAGES C CXX ASM)
+ find_package(Qt6BuildInternals COMPONENTS STANDALONE_TEST)
+endif()
+
+#####################################################################
+## headerview Binary:
+#####################################################################
+
+qt_internal_add_manual_test(headerview
+ GUI
+ SOURCES
+ main.cpp
+ PUBLIC_LIBRARIES
+ Qt::Gui
+ Qt::Qml
+ Qt::Quick
+ Qt::QuickControls2
+ Qt::QuickControls2Private
+ Qt::QuickPrivate
+ Qt::QuickTemplates2
+ Qt::QuickTemplates2Private
+)
+
+# Resources:
+set(qmake_immediate_resource_files
+ "main.qml"
+)
+
+qt_internal_add_resource(headerview "qmake_immediate"
+ PREFIX
+ "/"
+ FILES
+ ${qmake_immediate_resource_files}
+)
+
+
+#### Keys ignored in scope 1:.:.:headerview.pro:<TRUE>:
+# TEMPLATE = "app"
+
+## Scopes:
+#####################################################################
+
+#### Keys ignored in scope 2:.:.:headerview.pro:QNX:
+# target.path = "/tmp/$${TARGET}/bin"
+
+#### Keys ignored in scope 4:.:.:headerview.pro:UNIX AND NOT ANDROID:
+# target.path = "/opt/$${TARGET}/bin"
+
+#### Keys ignored in scope 5:.:.:headerview.pro:NOT target.path_ISEMPTY:
+# INSTALLS = "target"