aboutsummaryrefslogtreecommitdiffstats
path: root/tests/manual/quickcontrols2/systemtrayicon/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/manual/quickcontrols2/systemtrayicon/CMakeLists.txt')
-rw-r--r--tests/manual/quickcontrols2/systemtrayicon/CMakeLists.txt38
1 files changed, 38 insertions, 0 deletions
diff --git a/tests/manual/quickcontrols2/systemtrayicon/CMakeLists.txt b/tests/manual/quickcontrols2/systemtrayicon/CMakeLists.txt
new file mode 100644
index 0000000000..b44a44967a
--- /dev/null
+++ b/tests/manual/quickcontrols2/systemtrayicon/CMakeLists.txt
@@ -0,0 +1,38 @@
+# Generated from systemtrayicon.pro.
+
+if (NOT QT_BUILD_STANDALONE_TESTS AND NOT QT_BUILDING_QT)
+ cmake_minimum_required(VERSION 3.16)
+ project(systemtrayicon LANGUAGES C CXX ASM)
+ find_package(Qt6BuildInternals COMPONENTS STANDALONE_TEST)
+endif()
+
+#####################################################################
+## systemtrayicon Binary:
+#####################################################################
+
+qt_internal_add_manual_test(systemtrayicon
+ GUI
+ SOURCES
+ systemtrayicon.cpp
+ PUBLIC_LIBRARIES
+ Qt::Gui
+ Qt::Quick
+ Qt::QuickControls2
+)
+
+# Resources:
+set(systemtrayicon_resource_files
+ "images/qt_logo_green_256.png"
+ "systemtrayicon.qml"
+)
+
+qt_internal_add_resource(systemtrayicon "systemtrayicon"
+ PREFIX
+ "/files"
+ FILES
+ ${systemtrayicon_resource_files}
+)
+
+
+#### Keys ignored in scope 1:.:.:systemtrayicon.pro:<TRUE>:
+# TEMPLATE = "app"