aboutsummaryrefslogtreecommitdiffstats
path: root/tools/qmlcachegen/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tools/qmlcachegen/CMakeLists.txt')
-rw-r--r--tools/qmlcachegen/CMakeLists.txt9
1 files changed, 5 insertions, 4 deletions
diff --git a/tools/qmlcachegen/CMakeLists.txt b/tools/qmlcachegen/CMakeLists.txt
index d2c109d002..8bc705d3a8 100644
--- a/tools/qmlcachegen/CMakeLists.txt
+++ b/tools/qmlcachegen/CMakeLists.txt
@@ -4,7 +4,8 @@
## qmlcachegen Tool:
#####################################################################
-qt_add_tool(qmlcachegen
+qt_get_tool_target_name(target_name qmlcachegen)
+qt_add_tool(${target_name}
TARGET_DESCRIPTION "QML Cache Generator"
TOOLS_TARGET Qml # special case
SOURCES
@@ -29,9 +30,9 @@ qt_add_tool(qmlcachegen
# build_integration.files = "qmlcache.prf" "qtquickcompiler.prf"
# build_integration.path = "$$[QT_HOST_DATA]/mkspecs/features"
# cmake_build_integration.files = "$$cmake_config_file.output"
-# cmake_build_integration.path = "$$[QT_INSTALL_LIBS]/cmake/Qt5QuickCompiler"
-# cmake_config_file.input = "$$PWD/Qt5QuickCompilerConfig.cmake.in"
-# cmake_config_file.output = "$$MODULE_BASE_OUTDIR/lib/cmake/Qt5QuickCompiler/Qt5QuickCompilerConfig.cmake"
+# cmake_build_integration.path = "$$[QT_INSTALL_LIBS]/cmake/Qt6QuickCompiler"
+# cmake_config_file.input = "$$PWD/Qt6QuickCompilerConfig.cmake.in"
+# cmake_config_file.output = "$$MODULE_BASE_OUTDIR/lib/cmake/Qt6QuickCompiler/Qt6QuickCompilerConfig.cmake"
## Scopes:
#####################################################################