aboutsummaryrefslogtreecommitdiffstats
path: root/tools/qmlformat/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tools/qmlformat/CMakeLists.txt')
-rw-r--r--tools/qmlformat/CMakeLists.txt20
1 files changed, 20 insertions, 0 deletions
diff --git a/tools/qmlformat/CMakeLists.txt b/tools/qmlformat/CMakeLists.txt
new file mode 100644
index 0000000000..b83b8745d2
--- /dev/null
+++ b/tools/qmlformat/CMakeLists.txt
@@ -0,0 +1,20 @@
+# Generated from qmlformat.pro.
+
+#####################################################################
+## qmlformat Tool:
+#####################################################################
+
+qt_add_tool(qmlformat
+ TOOLS_TARGET Qml # special case
+ SOURCES
+ commentastvisitor.cpp commentastvisitor.h
+ dumpastvisitor.cpp dumpastvisitor.h
+ main.cpp
+ restructureastvisitor.cpp restructureastvisitor.h
+ PUBLIC_LIBRARIES
+ Qt::QmlDevToolsPrivate
+)
+
+#### Keys ignored in scope 1:.:.:qmlformat.pro:<TRUE>:
+# QMAKE_TARGET_DESCRIPTION = "QML" "Formatter"
+# _OPTION = "host_build"