aboutsummaryrefslogtreecommitdiffstats
path: root/tools/qmllint/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tools/qmllint/CMakeLists.txt')
-rw-r--r--tools/qmllint/CMakeLists.txt11
1 files changed, 7 insertions, 4 deletions
diff --git a/tools/qmllint/CMakeLists.txt b/tools/qmllint/CMakeLists.txt
index d4b0aad760..d294c2c78e 100644
--- a/tools/qmllint/CMakeLists.txt
+++ b/tools/qmllint/CMakeLists.txt
@@ -7,14 +7,17 @@
qt_add_tool(qmllint
TOOLS_TARGET Qml # special case
SOURCES
- componentversion.cpp componentversion.h
+ checkidentifiers.cpp checkidentifiers.h
+ ../shared/componentversion.cpp ../shared/componentversion.h
findunqualified.cpp findunqualified.h
importedmembersvisitor.cpp importedmembersvisitor.h
main.cpp
- metatypes.h
+ ../shared/metatypes.h
qcoloroutput.cpp qcoloroutput.h
- scopetree.cpp scopetree.h
- typedescriptionreader.cpp typedescriptionreader.h
+ ../shared/scopetree.cpp ../shared/scopetree.h
+ ../shared/typedescriptionreader.cpp ../shared/typedescriptionreader.h
+ INCLUDE_DIRECTORIES
+ ../shared
PUBLIC_LIBRARIES
Qt::CorePrivate
Qt::QmlDevToolsPrivate