aboutsummaryrefslogtreecommitdiffstats
path: root/tools/qmlplugindump/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tools/qmlplugindump/CMakeLists.txt')
-rw-r--r--tools/qmlplugindump/CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/tools/qmlplugindump/CMakeLists.txt b/tools/qmlplugindump/CMakeLists.txt
index 57f96a1f94..887fe0999e 100644
--- a/tools/qmlplugindump/CMakeLists.txt
+++ b/tools/qmlplugindump/CMakeLists.txt
@@ -4,7 +4,7 @@
## qmlplugindump Tool:
#####################################################################
-add_qt_tool(qmlplugindump
+qt_add_tool(qmlplugindump
TOOLS_TARGET Qml # special case
SOURCES
main.cpp
@@ -27,12 +27,12 @@ add_qt_tool(qmlplugindump
## Scopes:
#####################################################################
-extend_target(qmlplugindump CONDITION TARGET Qt::Widgets
+qt_extend_target(qmlplugindump CONDITION TARGET Qt::Widgets
PUBLIC_LIBRARIES
Qt::Widgets
)
-extend_target(qmlplugindump CONDITION APPLE_OSX
+qt_extend_target(qmlplugindump CONDITION APPLE_OSX
LINK_OPTIONS
"-Wl,-sectcreate,__TEXT,__info_plist,${CMAKE_CURRENT_SOURCE_DIR}/Info.plist" # special case
)