aboutsummaryrefslogtreecommitdiffstats
path: root/tools/qmlscene/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tools/qmlscene/CMakeLists.txt')
-rw-r--r--tools/qmlscene/CMakeLists.txt7
1 files changed, 4 insertions, 3 deletions
diff --git a/tools/qmlscene/CMakeLists.txt b/tools/qmlscene/CMakeLists.txt
index c5dda83fd8..7e385653c1 100644
--- a/tools/qmlscene/CMakeLists.txt
+++ b/tools/qmlscene/CMakeLists.txt
@@ -4,7 +4,8 @@
## qmlscene Tool:
#####################################################################
-qt_add_tool(qmlscene
+qt_get_tool_target_name(target_name qmlscene)
+qt_add_tool(${target_name}
TARGET_DESCRIPTION "QML Scene Viewer"
TOOLS_TARGET Qml # special case
SOURCES
@@ -26,12 +27,12 @@ qt_add_tool(qmlscene
## Scopes:
#####################################################################
-qt_extend_target(qmlscene CONDITION TARGET Qt::Widgets
+qt_extend_target(${target_name} CONDITION TARGET Qt::Widgets
PUBLIC_LIBRARIES
Qt::Widgets
)
-qt_extend_target(qmlscene CONDITION QT_FEATURE_qml_debug
+qt_extend_target(${target_name} CONDITION QT_FEATURE_qml_debug
DEFINES
QT_QML_DEBUG_NO_WARNING
)