aboutsummaryrefslogtreecommitdiffstats
path: root/tools/qmlscene/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tools/qmlscene/CMakeLists.txt')
-rw-r--r--tools/qmlscene/CMakeLists.txt38
1 files changed, 38 insertions, 0 deletions
diff --git a/tools/qmlscene/CMakeLists.txt b/tools/qmlscene/CMakeLists.txt
new file mode 100644
index 0000000000..e9796871f5
--- /dev/null
+++ b/tools/qmlscene/CMakeLists.txt
@@ -0,0 +1,38 @@
+# Generated from qmlscene.pro.
+
+#####################################################################
+## qmlscene Tool:
+#####################################################################
+
+add_qt_tool(qmlscene
+ TOOLS_TARGET Qml # special case
+ SOURCES
+ main.cpp
+ DEFINES
+ QML_RUNTIME_TESTING
+ LIBRARIES
+ Qt::CorePrivate
+ Qt::GuiPrivate
+ Qt::QuickPrivate
+ PUBLIC_LIBRARIES
+ Qt::Gui
+ Qt::Qml
+ Qt::Quick
+)
+
+#### Keys ignored in scope 1:.:.:qmlscene.pro:<TRUE>:
+# QMAKE_TARGET_DESCRIPTION = "QML" "Scene" "Viewer"
+# _LOADED = "qt_tool"
+
+## Scopes:
+#####################################################################
+
+extend_target(qmlscene CONDITION TARGET Qt::Widgets
+ PUBLIC_LIBRARIES
+ Qt::Widgets
+)
+
+extend_target(qmlscene CONDITION QT_FEATURE_qml_debug
+ DEFINES
+ QT_QML_DEBUG_NO_WARNING
+)