aboutsummaryrefslogtreecommitdiffstats
path: root/tools/qmltime/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tools/qmltime/CMakeLists.txt')
-rw-r--r--tools/qmltime/CMakeLists.txt15
1 files changed, 12 insertions, 3 deletions
diff --git a/tools/qmltime/CMakeLists.txt b/tools/qmltime/CMakeLists.txt
index 4fb203cfbe..03425e9ecf 100644
--- a/tools/qmltime/CMakeLists.txt
+++ b/tools/qmltime/CMakeLists.txt
@@ -7,18 +7,27 @@
qt_add_executable(qmltime
GUI
SOURCES
- qmltime.cpp
- LIBRARIES
- Qt::QuickPrivate
+ qmltime.cpp qmltime.h
PUBLIC_LIBRARIES
Qt::Gui
Qt::Qml
Qt::Quick
+ Qt::QuickPrivate
)
#### Keys ignored in scope 1:.:.:qmltime.pro:<TRUE>:
# QMAKE_TARGET_DESCRIPTION = "QML" "Time"
+# QML_IMPORT_NAME = "QmlTime"
+# QML_IMPORT_VERSION = "1.0"
# TEMPLATE = "app"
## Scopes:
#####################################################################
+
+set_target_properties(qmltime PROPERTIES
+ QT_QML_MODULE_INSTALL_QMLTYPES TRUE
+ QT_QML_MODULE_VERSION 1.0
+ QT_QML_MODULE_URI QmlTime
+)
+
+qt6_qml_type_registration(qmltime)