summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPasi Petäjäjärvi <pasi.petajajarvi@qt.io>2021-11-02 19:59:44 +0200
committerQt Cherry-pick Bot <cherrypick_bot@qt-project.org>2021-12-14 17:47:03 +0000
commit8f4bb3a6a75d0396afdcc6550cc6c047e3d1bb3c (patch)
tree4e3c0d92970e49f53d2828d08a6d488efab3123e /CMakeLists.txt
parentf54069c20f19c79022852023ce9ab0cb763b37be (diff)
Refactor SettingsUI source code and add QML module support
Split application and plugins structure to use QML modules feature Move settingsui binary and plugins it uses under examples as those are not really documented nor production quality. Task-number: QTBUG-97737 Change-Id: I4b030a5a42b29554a45c23eab4170be980cd5dc5 Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org> Reviewed-by: Ulf Hermann <ulf.hermann@qt.io> (cherry picked from commit b3e6e77de4461cbfe5f29eeda9cc00bed61ce39c) Reviewed-by: Qt Cherry-pick Bot <cherrypick_bot@qt-project.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5fd523a..090928a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -8,8 +8,8 @@ project(QtDeviceUtilities
LANGUAGES CXX C
)
-find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals)
-find_package(Qt6 ${PROJECT_VERSION} CONFIG OPTIONAL_COMPONENTS Quick DBus)
+find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Core)
+find_package(Qt6 ${PROJECT_VERSION} QUIET CONFIG OPTIONAL_COMPONENTS Gui Network Quick Qml QuickControls2 DBus)
macro(assertTargets)
foreach(qtTarget IN ITEMS ${ARGN})