summaryrefslogtreecommitdiffstats
path: root/src/networksettings/CMakeLists.txt
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2021-09-17 11:33:13 +0300
committerQt Cherry-pick Bot <cherrypick_bot@qt-project.org>2021-09-23 09:23:26 +0000
commit346e700b1ff0e570ff7be79f3e275952c89aa316 (patch)
treea578a3a3e0fbefdacfba2eacd18fd39d4734cc85 /src/networksettings/CMakeLists.txt
parentd409a2e58e4285f88656a487bfd2cf194753b932 (diff)
CMake: use LIBRARIES in plugins
Fix CMake warnings caused by using PUBLIC_LIBRARIES in plugins. Plugins are not intended to be linked to. They should not have any public properties, but LIBRARIES instead of PUBLIC_LIBRARIES. Change-Id: I35644c7ea97f03f26086c2ae5d2ea14a9e7a0a78 Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io> (cherry picked from commit 27f7f769ba345d7899e4dc10b43a477ababbc99a) Reviewed-by: Qt Cherry-pick Bot <cherrypick_bot@qt-project.org>
Diffstat (limited to 'src/networksettings/CMakeLists.txt')
-rw-r--r--src/networksettings/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/networksettings/CMakeLists.txt b/src/networksettings/CMakeLists.txt
index 083b43f..daf0b30 100644
--- a/src/networksettings/CMakeLists.txt
+++ b/src/networksettings/CMakeLists.txt
@@ -27,7 +27,7 @@ qt_internal_add_module(NetworkSettings
-iconnmancommon.h # special case
INCLUDE_DIRECTORIES
connman
- PUBLIC_LIBRARIES
+ LIBRARIES
Qt::Core
Qt::DBus
Qt::Network