summaryrefslogtreecommitdiffstats
path: root/src/settingsui/CMakeLists.txt
diff options
context:
space:
mode:
authorLassi Lehikoinen <lassi.lehikoinen@qt.io>2020-12-02 13:05:03 +0200
committerLassi Lehikoinen <lassi.lehikoinen@qt.io>2020-12-16 11:49:17 +0200
commitaa9223a4d7d410aa8a12495fef5c3f36a2c79ffe (patch)
treeb35a38a32991d120e5b3b6ebe1d14bef326bd34e /src/settingsui/CMakeLists.txt
parent1ace321e373ad19287c41cef9ae17fcfb7ab938d (diff)
Build device utilities with CMake and qmake against Qt 6
Also fix compiler warnings. Task-number: QTBUG-88317 Change-Id: Iff6014613a7d12426b6fe692dff0000c92930ace Reviewed-by: Samuli Piippo <samuli.piippo@qt.io>
Diffstat (limited to 'src/settingsui/CMakeLists.txt')
-rw-r--r--src/settingsui/CMakeLists.txt88
1 files changed, 88 insertions, 0 deletions
diff --git a/src/settingsui/CMakeLists.txt b/src/settingsui/CMakeLists.txt
new file mode 100644
index 0000000..e7801db
--- /dev/null
+++ b/src/settingsui/CMakeLists.txt
@@ -0,0 +1,88 @@
+# Generated from settingsui.pro.
+
+#####################################################################
+## settingsui Binary:
+#####################################################################
+
+qt_add_executable(settingsui
+ GUI
+ SOURCES
+ main.cpp
+ PUBLIC_LIBRARIES
+ Qt::Gui
+ Qt::Qml
+ Qt::Quick
+)
+
+# Resources:
+set(settingsuiapp_resource_files
+ "AutoScroller.qml"
+ "ViewSettings.qml"
+ "common/CustomSwitch.qml"
+ "common/HandwritingModeButton.qml"
+ "main.qml"
+ "network/AddressListEntry.qml"
+ "network/ComboBoxEntry.qml"
+ "network/EditWiredSettings.qml"
+ "network/IpAddressTextField.qml"
+ "network/NetworkDetails.qml"
+ "network/NetworkListView.qml"
+ "network/NetworkSettings.qml"
+ "network/PassphraseEnter.qml"
+ "network/WifiSelectorDelegate.qml"
+ "network/WifiSettings.qml"
+ "network/WifiSignalMonitor.qml"
+ "network/WiredSettings.qml"
+ "settingsuiplugin/SettingsDelegate.qml"
+ "settingsuiplugin/SettingsHeader.qml"
+ "settingsuiplugin/SettingsTitleItem.qml"
+ "settingsuiplugin/pluginMain.qml"
+)
+
+qt_add_resource(settingsui "settingsuiapp"
+ PREFIX
+ "/"
+ FILES
+ ${settingsuiapp_resource_files}
+)
+
+
+#### Keys ignored in scope 1:.:.:settingsui.pro:<TRUE>:
+# QML_IMPORT_PATH = <EMPTY>
+# TEMPLATE = "app"
+
+## Scopes:
+#####################################################################
+
+qt_extend_target(settingsui CONDITION static
+ PUBLIC_LIBRARIES
+ Qt::Svg
+)
+
+#### Keys ignored in scope 2:.:.:settingsui.pro:static:
+# QTPLUGIN = "qtvirtualkeyboardplugin"
+
+#### Keys ignored in scope 4:.:.:deployment.pri:android-no-sdk:
+# INSTALLS = "target"
+# target.path = "/data/user/qt"
+
+#### Keys ignored in scope 6:.:.:deployment.pri:ANDROID:
+# INSTALLS = "target"
+
+#### Keys ignored in scope 7:.:.:deployment.pri:TEST_architecture_arch STREQUAL i386:
+# target.path = "/libs/x86"
+
+#### Keys ignored in scope 9:.:.:deployment.pri:TEST_architecture_arch STREQUAL arm:
+# target.path = "/libs/armeabi-v7a"
+
+#### Keys ignored in scope 10:.:.:deployment.pri:else:
+# target.path = "/libs/armeabi"
+
+#### Keys ignored in scope 12:.:.:deployment.pri:UNIX:
+# INSTALLS = "target"
+
+#### Keys ignored in scope 14:.:.:deployment.pri:QNX:
+# target.path = "/tmp/$${TARGET}/bin"
+
+#### Keys ignored in scope 15:.:.:deployment.pri:else:
+# target.path = "$$[QT_INSTALL_BINS]"