summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt24
1 files changed, 24 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..d5bedf8
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,24 @@
+# Generated from qtdeviceutilities.pro.
+
+cmake_minimum_required(VERSION 3.15.0)
+
+include(.cmake.conf)
+project(QtDeviceUtilities # special case
+ VERSION "${QT_REPO_MODULE_VERSION}"
+ DESCRIPTION "Qt Device Utilities Libraries" # special case
+ HOMEPAGE_URL "https://qt.io/"
+ LANGUAGES CXX C
+)
+
+find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Quick DBus) # special case
+find_package(Qt6 ${PROJECT_VERSION} CONFIG OPTIONAL_COMPONENTS)
+
+if(NOT LINUX)
+ message(NOTICE "Skipping the build as the condition \"LINUX\" is not met.")
+ return()
+endif()
+if(NOT TARGET Qt::Quick)
+ message(NOTICE "Skipping the build as the condition \"TARGET Qt::Quick\" is not met.")
+ return()
+endif()
+qt_build_repo()