summaryrefslogtreecommitdiffstats
path: root/src/settingsui/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/settingsui/CMakeLists.txt')
-rw-r--r--src/settingsui/CMakeLists.txt44
1 files changed, 3 insertions, 41 deletions
diff --git a/src/settingsui/CMakeLists.txt b/src/settingsui/CMakeLists.txt
index e7801db..5bec7ee 100644
--- a/src/settingsui/CMakeLists.txt
+++ b/src/settingsui/CMakeLists.txt
@@ -1,10 +1,8 @@
-# Generated from settingsui.pro.
-
#####################################################################
## settingsui Binary:
#####################################################################
-qt_add_executable(settingsui
+qt_internal_add_executable(settingsui
GUI
SOURCES
main.cpp
@@ -39,50 +37,14 @@ set(settingsuiapp_resource_files
"settingsuiplugin/pluginMain.qml"
)
-qt_add_resource(settingsui "settingsuiapp"
+qt_internal_add_resource(settingsui "settingsuiapp"
PREFIX
"/"
FILES
${settingsuiapp_resource_files}
)
-
-#### Keys ignored in scope 1:.:.:settingsui.pro:<TRUE>:
-# QML_IMPORT_PATH = <EMPTY>
-# TEMPLATE = "app"
-
-## Scopes:
-#####################################################################
-
-qt_extend_target(settingsui CONDITION static
+qt_internal_extend_target(settingsui CONDITION static
PUBLIC_LIBRARIES
Qt::Svg
)
-
-#### Keys ignored in scope 2:.:.:settingsui.pro:static:
-# QTPLUGIN = "qtvirtualkeyboardplugin"
-
-#### Keys ignored in scope 4:.:.:deployment.pri:android-no-sdk:
-# INSTALLS = "target"
-# target.path = "/data/user/qt"
-
-#### Keys ignored in scope 6:.:.:deployment.pri:ANDROID:
-# INSTALLS = "target"
-
-#### Keys ignored in scope 7:.:.:deployment.pri:TEST_architecture_arch STREQUAL i386:
-# target.path = "/libs/x86"
-
-#### Keys ignored in scope 9:.:.:deployment.pri:TEST_architecture_arch STREQUAL arm:
-# target.path = "/libs/armeabi-v7a"
-
-#### Keys ignored in scope 10:.:.:deployment.pri:else:
-# target.path = "/libs/armeabi"
-
-#### Keys ignored in scope 12:.:.:deployment.pri:UNIX:
-# INSTALLS = "target"
-
-#### Keys ignored in scope 14:.:.:deployment.pri:QNX:
-# target.path = "/tmp/$${TARGET}/bin"
-
-#### Keys ignored in scope 15:.:.:deployment.pri:else:
-# target.path = "$$[QT_INSTALL_BINS]"