summaryrefslogtreecommitdiffstats
path: root/examples/demos/dice/CMakeLists.txt
diff options
context:
space:
mode:
authorNicholas Bennett <nicholas.bennett@qt.io>2023-11-27 13:24:54 +0200
committerAssam Boudjelthia <assam.boudjelthia@qt.io>2023-12-04 09:02:05 +0000
commit81d73cdbb5606e7db49957d72cc5cdc8d56b3825 (patch)
tree8baa8901a29d3205f7aac48163a5a56b6cafc3e0 /examples/demos/dice/CMakeLists.txt
parent232d968fd2dbfe6b75e23d07c09d6c15c09b4a97 (diff)
Add Android icon and target SDK for dice example app
Added target SDK 33 with CMake and added icon for Android target, using Qt creator to generate icons and the AndroidManifest xml file. Gradle files were excluded. Task-number: QTBUG-118513 Pick-to: 6.6 Change-Id: I57953099350017975702309496e4e4f1a87e9d1f Reviewed-by: Assam Boudjelthia <assam.boudjelthia@qt.io>
Diffstat (limited to 'examples/demos/dice/CMakeLists.txt')
-rw-r--r--examples/demos/dice/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/examples/demos/dice/CMakeLists.txt b/examples/demos/dice/CMakeLists.txt
index fc366bd1d..2153b959a 100644
--- a/examples/demos/dice/CMakeLists.txt
+++ b/examples/demos/dice/CMakeLists.txt
@@ -60,6 +60,11 @@ set(qml_resource_files
sounds/onedice.wav
sounds/rolling.wav
)
+if(ANDROID)
+ set_target_properties(dice PROPERTIES
+ QT_ANDROID_PACKAGE_SOURCE_DIR "${CMAKE_CURRENT_SOURCE_DIR}/android"
+ QT_ANDROID_TARGET_SDK_VERSION "33")
+endif()
qt_add_resources(dice "qml"
PREFIX