summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorFriedemann Kleint <Friedemann.Kleint@qt.io>2023-02-08 15:40:56 +0100
committerQt Cherry-pick Bot <cherrypick_bot@qt-project.org>2023-02-08 18:09:49 +0000
commit6c0a5819ccffb80fe5b76369a450980fa6911b22 (patch)
tree61c771ff7847954a928d4bb7ee84930b306d2c24 /CMakeLists.txt
parent564db075930e60deb6694d5d50f2d1d79b06209e (diff)
Remove remains of qmake conversion from CMakeLists.txt files
Change-Id: Ic00df7d45246270d724b3b1d1ef9d13d76dcc136 Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io> (cherry picked from commit 93ece87be2bf7a8e905e1b462ae7705280603a27) Reviewed-by: Qt Cherry-pick Bot <cherrypick_bot@qt-project.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 4 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 947a5f3..684482d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,20 +1,18 @@
# Copyright (C) 2022 The Qt Company Ltd.
# SPDX-License-Identifier: BSD-3-Clause
-# Generated from qtimageformats.pro.
-
cmake_minimum_required(VERSION 3.16)
include(.cmake.conf)
-project(QtImageFormats # special case
+project(QtImageFormats
VERSION "${QT_REPO_MODULE_VERSION}"
- DESCRIPTION "Qt ImageFormats Libraries" # special case
+ DESCRIPTION "Qt ImageFormats Libraries"
HOMEPAGE_URL "https://qt.io/"
LANGUAGES CXX C
)
-find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Core) # special case
-find_package(Qt6 ${PROJECT_VERSION} QUIET CONFIG OPTIONAL_COMPONENTS Gui) # special case
+find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Core)
+find_package(Qt6 ${PROJECT_VERSION} QUIET CONFIG OPTIONAL_COMPONENTS Gui)
if(NOT TARGET Qt::Gui)
message(NOTICE "Skipping the build as the condition \"TARGET Qt::Gui\" is not met.")
return()