summaryrefslogtreecommitdiffstats
path: root/src/plugins/imageformats/macheif/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2020-03-16 17:07:41 +0100
committerAlexandru Croitor <alexandru.croitor@qt.io>2020-03-16 18:02:19 +0000
commitc96422ae949b151399be50d606cc40ecfb7e6ddb (patch)
tree688ff72b94eb67d6c0a3d164947c3f040843cdcd /src/plugins/imageformats/macheif/CMakeLists.txt
parent51e7fa714ca76fd9edb342fc8e97451086e46fe3 (diff)
CMake: Regenerate and fixup qtimageformats projectswip/cmake
A few changes happened since last update: - CMake target names are now consistent with Qt 5 names - ZLIB handling - TIFF 3rd party handling - Standalone tests simplification - Updates in the SUBDIRS project - Other minor changes Change-Id: I85cca79d38feca44c5b78dae48c79779ae05e288 Reviewed-by: Simon Hausmann <simon.hausmann@qt.io>
Diffstat (limited to 'src/plugins/imageformats/macheif/CMakeLists.txt')
-rw-r--r--src/plugins/imageformats/macheif/CMakeLists.txt11
1 files changed, 5 insertions, 6 deletions
diff --git a/src/plugins/imageformats/macheif/CMakeLists.txt b/src/plugins/imageformats/macheif/CMakeLists.txt
index 6df9758..7d90b40 100644
--- a/src/plugins/imageformats/macheif/CMakeLists.txt
+++ b/src/plugins/imageformats/macheif/CMakeLists.txt
@@ -1,7 +1,7 @@
# Generated from macheif.pro.
#####################################################################
-## qmacheif Plugin:
+## QMacHeifPlugin Plugin:
#####################################################################
# special case begin
@@ -10,24 +10,23 @@ find_library(FWCoreGraphics CoreGraphics)
find_library(FWImageIO ImageIO)
# special case end
-qt_add_plugin(qmacheif
+qt_add_plugin(QMacHeifPlugin
+ OUTPUT_NAME qmacheif
TYPE imageformats
- CLASS_NAME QMacHeifPlugin
SOURCES
../shared/qiiofhelpers.cpp ../shared/qiiofhelpers_p.h
main.cpp
qmacheifhandler.cpp qmacheifhandler.h
INCLUDE_DIRECTORIES
../shared
- LIBRARIES
- Qt::CorePrivate
- Qt::GuiPrivate
PUBLIC_LIBRARIES
${FWCoreFoundation}
${FWCoreGraphics}
${FWImageIO}
Qt::Core
+ Qt::CorePrivate
Qt::Gui
+ Qt::GuiPrivate
)
#### Keys ignored in scope 1:.:.:macheif.pro:<TRUE>: