summaryrefslogtreecommitdiffstats
path: root/src/plugins/imageformats/webp/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2020-03-16 17:07:41 +0100
committerAlexandru Croitor <alexandru.croitor@qt.io>2020-03-16 18:02:19 +0000
commitc96422ae949b151399be50d606cc40ecfb7e6ddb (patch)
tree688ff72b94eb67d6c0a3d164947c3f040843cdcd /src/plugins/imageformats/webp/CMakeLists.txt
parent51e7fa714ca76fd9edb342fc8e97451086e46fe3 (diff)
CMake: Regenerate and fixup qtimageformats projectswip/cmake
A few changes happened since last update: - CMake target names are now consistent with Qt 5 names - ZLIB handling - TIFF 3rd party handling - Standalone tests simplification - Updates in the SUBDIRS project - Other minor changes Change-Id: I85cca79d38feca44c5b78dae48c79779ae05e288 Reviewed-by: Simon Hausmann <simon.hausmann@qt.io>
Diffstat (limited to 'src/plugins/imageformats/webp/CMakeLists.txt')
-rw-r--r--src/plugins/imageformats/webp/CMakeLists.txt10
1 files changed, 6 insertions, 4 deletions
diff --git a/src/plugins/imageformats/webp/CMakeLists.txt b/src/plugins/imageformats/webp/CMakeLists.txt
index 1385e63..b1edce6 100644
--- a/src/plugins/imageformats/webp/CMakeLists.txt
+++ b/src/plugins/imageformats/webp/CMakeLists.txt
@@ -1,12 +1,12 @@
# Generated from webp.pro.
#####################################################################
-## qwebp Plugin:
+## QWebpPlugin Plugin:
#####################################################################
-qt_add_plugin(qwebp
+qt_add_plugin(QWebpPlugin
+ OUTPUT_NAME qwebp
TYPE imageformats
- CLASS_NAME QWebpPlugin
SOURCES
main.cpp
qwebphandler.cpp qwebphandler_p.h
@@ -14,9 +14,11 @@ qt_add_plugin(qwebp
Qt::Core
Qt::Gui
WrapWebP::WrapWebP
- Qt::Gui # special case
)
#### Keys ignored in scope 1:.:.:webp.pro:<TRUE>:
# OTHER_FILES = "webp.json"
# QT_FOR_CONFIG = "imageformats-private"
+
+## Scopes:
+#####################################################################