summaryrefslogtreecommitdiffstats
path: root/src/plugins/imageformats/macheif/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugins/imageformats/macheif/CMakeLists.txt')
-rw-r--r--src/plugins/imageformats/macheif/CMakeLists.txt7
1 files changed, 4 insertions, 3 deletions
diff --git a/src/plugins/imageformats/macheif/CMakeLists.txt b/src/plugins/imageformats/macheif/CMakeLists.txt
index b22cced..c64510b 100644
--- a/src/plugins/imageformats/macheif/CMakeLists.txt
+++ b/src/plugins/imageformats/macheif/CMakeLists.txt
@@ -5,9 +5,10 @@
## QMacHeifPlugin Plugin:
#####################################################################
-find_library(FWCoreFoundation CoreFoundation)
-find_library(FWCoreGraphics CoreGraphics)
-find_library(FWImageIO ImageIO)
+qt_internal_find_apple_system_framework(FWCoreFoundation
+ CoreFoundation)
+qt_internal_find_apple_system_framework(FWCoreGraphics CoreGraphics)
+qt_internal_find_apple_system_framework(FWImageIO ImageIO)
qt_internal_add_plugin(QMacHeifPlugin
OUTPUT_NAME qmacheif