summaryrefslogtreecommitdiffstats
path: root/src/plugins/imageformats/webp/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugins/imageformats/webp/CMakeLists.txt')
-rw-r--r--src/plugins/imageformats/webp/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/src/plugins/imageformats/webp/CMakeLists.txt b/src/plugins/imageformats/webp/CMakeLists.txt
index ceef4b0..25aa0c9 100644
--- a/src/plugins/imageformats/webp/CMakeLists.txt
+++ b/src/plugins/imageformats/webp/CMakeLists.txt
@@ -29,6 +29,11 @@ qt_internal_extend_target(QWebpPlugin CONDITION QT_FEATURE_system_webp
qt_internal_extend_target(QWebpPlugin CONDITION NOT QT_FEATURE_system_webp
SOURCES
+ ../../../3rdparty/libwebp/sharpyuv/sharpyuv.c
+ ../../../3rdparty/libwebp/sharpyuv/sharpyuv_csp.c
+ ../../../3rdparty/libwebp/sharpyuv/sharpyuv_dsp.c
+ ../../../3rdparty/libwebp/sharpyuv/sharpyuv_gamma.c
+ ../../../3rdparty/libwebp/sharpyuv/sharpyuv_sse2.c
../../../3rdparty/libwebp/src/dec/alpha_dec.c
../../../3rdparty/libwebp/src/dec/buffer_dec.c
../../../3rdparty/libwebp/src/dec/frame_dec.c
@@ -136,6 +141,7 @@ qt_internal_extend_target(QWebpPlugin CONDITION NOT QT_FEATURE_system_webp
../../../3rdparty/libwebp/src/utils/utils.c
INCLUDE_DIRECTORIES
../../../3rdparty/libwebp
+ ../../../3rdparty/libwebp/sharpyuv
../../../3rdparty/libwebp/src
../../../3rdparty/libwebp/src/dec
../../../3rdparty/libwebp/src/dsp
@@ -154,6 +160,7 @@ qt_internal_extend_target(QWebpPlugin CONDITION ANDROID AND NOT ANDROID_EMBEDDED
# special case begin
set(neon_sources
+ ../../../3rdparty/libwebp/sharpyuv/sharpyuv_neon.c
../../../3rdparty/libwebp/src/dsp/alpha_processing_neon.c
../../../3rdparty/libwebp/src/dsp/dec_neon.c
../../../3rdparty/libwebp/src/dsp/enc_neon.c