summaryrefslogtreecommitdiffstats
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt9
1 files changed, 3 insertions, 6 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 97ac2c2..5a389d6 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -1,13 +1,10 @@
# Generated from tests.pro.
-# special case begin
if(NOT TARGET Qt::Test)
cmake_minimum_required(VERSION 3.15.0)
- project(QtImageFormatsTests VERSION 6.0.0 LANGUAGES C CXX ASM)
- find_package(Qt6 REQUIRED COMPONENTS BuildInternals Core Test
- OPTIONAL_COMPONENTS Gui)
+ project(imageformatsTests_FIXME VERSION 6.0.0 LANGUAGES C CXX)
+ find_package(Qt6 ${PROJECT_VERSION} REQUIRED COMPONENTS BuildInternals Core Test) # special case
+ find_package(Qt6 ${PROJECT_VERSION} OPTIONAL_COMPONENTS Gui) # special case
qt_set_up_standalone_tests_build()
endif()
-# special case end
-
qt_build_tests()