summaryrefslogtreecommitdiffstats
path: root/tests/auto/tga/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/tga/CMakeLists.txt')
-rw-r--r--tests/auto/tga/CMakeLists.txt18
1 files changed, 14 insertions, 4 deletions
diff --git a/tests/auto/tga/CMakeLists.txt b/tests/auto/tga/CMakeLists.txt
index 25c1441..f6e1760 100644
--- a/tests/auto/tga/CMakeLists.txt
+++ b/tests/auto/tga/CMakeLists.txt
@@ -12,9 +12,19 @@ add_qt_test(tst_qtga
)
# Resources:
-add_qt_resource(tst_qtga "tga" PREFIX "/" BASE "../../shared/images" FILES
- tga/test-flag.tga)
+set_source_files_properties("../../shared/images/tga/test-flag.tga"
+ PROPERTIES QT_RESOURCE_ALIAS "tga/test-flag.tga"
+)
+set(tga_resource_files
+ "tga/test-flag.tga"
+)
+add_qt_resource(tst_qtga "tga"
+ PREFIX
+ "/"
+ BASE
+ "../../shared/images"
+ FILES
+ ${tga_resource_files}
+)
-#### Keys ignored in scope 1:.:.:tga.pro:<TRUE>:
-# CONFIG = "-app_bundle" "testcase"