summaryrefslogtreecommitdiffstats
path: root/tests/auto/wbmp/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/wbmp/CMakeLists.txt')
-rw-r--r--tests/auto/wbmp/CMakeLists.txt23
1 files changed, 18 insertions, 5 deletions
diff --git a/tests/auto/wbmp/CMakeLists.txt b/tests/auto/wbmp/CMakeLists.txt
index 2db456b..9b7a3fb 100644
--- a/tests/auto/wbmp/CMakeLists.txt
+++ b/tests/auto/wbmp/CMakeLists.txt
@@ -12,10 +12,23 @@ add_qt_test(tst_qwbmp
)
# Resources:
-add_qt_resource(tst_qwbmp "wbmp" PREFIX "/" BASE "../../shared/images" FILES
- wbmp/qt-logo-big.wbmp
- wbmp/qt-logo-small.wbmp)
+set_source_files_properties("../../shared/images/wbmp/qt-logo-big.wbmp"
+ PROPERTIES QT_RESOURCE_ALIAS "wbmp/qt-logo-big.wbmp"
+)
+set_source_files_properties("../../shared/images/wbmp/qt-logo-small.wbmp"
+ PROPERTIES QT_RESOURCE_ALIAS "wbmp/qt-logo-small.wbmp"
+)
+set(wbmp_resource_files
+ "wbmp/qt-logo-big.wbmp"
+ "wbmp/qt-logo-small.wbmp"
+)
+add_qt_resource(tst_qwbmp "wbmp"
+ PREFIX
+ "/"
+ BASE
+ "../../shared/images"
+ FILES
+ ${wbmp_resource_files}
+)
-#### Keys ignored in scope 1:.:.:wbmp.pro:<TRUE>:
-# CONFIG = "-app_bundle" "testcase"