summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDominik Holland <dominik.holland@qt.io>2021-11-02 14:04:50 +0100
committerDominik Holland <dominik.holland@qt.io>2021-11-02 15:30:14 +0100
commitff0db1360ca9dd83661acc41ab4795d7dae42029 (patch)
tree3711d35a3c7eae5c6ec123f18d50eedcaebfd753 /CMakeLists.txt
parent17465a5b84797cd50b10323a2554156bf805e68a (diff)
Mark the module as not free of warnings
This is caused by QTBUG-97790 (repc) Pick-to: 6.2 Change-Id: Ie369896b3b0febfb08eaa4864e01b77f22a54fd8 Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org> Reviewed-by: Robert Griebl <robert.griebl@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f9de977d..6ff59e98 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -10,6 +10,9 @@ project(QtInterfaceFramework
LANGUAGES CXX C
)
+# TODO: Fix warnings and remove this
+set(QT_REPO_NOT_WARNINGS_CLEAN TRUE)
+
# Make sure we only use latest private CMake API, aka no compatibility wrappers.
set(QT_NO_INTERNAL_COMPATIBILITY_FUNCTIONS TRUE)