summaryrefslogtreecommitdiffstats
path: root/tests/auto/conformance/CMakeLists.txt
diff options
context:
space:
mode:
authorMaurice Kalinowski <maurice.kalinowski@qt.io>2019-08-29 10:42:00 +0200
committerMaurice Kalinowski <maurice.kalinowski@qt.io>2019-09-02 07:06:48 +0000
commit4e5af443ef542e191a98b456add6d8e89dc2d408 (patch)
treea2ed4ead3bbf407829623ea2a6f270e3d732432a /tests/auto/conformance/CMakeLists.txt
parentb3b75fd0c5b2d7454009bd0bc878632475d7b131 (diff)
Add initial support for cmake
Change-Id: I40153b0f225d67afebfaf3ff0b1c43a9c2f69b8c Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'tests/auto/conformance/CMakeLists.txt')
-rw-r--r--tests/auto/conformance/CMakeLists.txt21
1 files changed, 21 insertions, 0 deletions
diff --git a/tests/auto/conformance/CMakeLists.txt b/tests/auto/conformance/CMakeLists.txt
new file mode 100644
index 0000000..b3b2e63
--- /dev/null
+++ b/tests/auto/conformance/CMakeLists.txt
@@ -0,0 +1,21 @@
+# Generated from conformance.pro.
+
+#####################################################################
+## tst_conformance Test:
+#####################################################################
+
+add_qt_test(tst_conformance
+ GUI
+ SOURCES
+ ../../common/broker_connection.h
+ tst_conformance.cpp
+ DEFINES
+ SRCDIR=\\\"${CMAKE_CURRENT_SOURCE_DIR}/\\\"
+ INCLUDE_DIRECTORIES
+ ../../common
+ LIBRARIES
+ Qt::MqttPrivate
+ PUBLIC_LIBRARIES
+ Qt::Mqtt
+ Qt::Network
+)