summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAssam Boudjelthia <assam.boudjelthia@qt.io>2021-08-02 12:54:28 +0300
committerAssam Boudjelthia <assam.boudjelthia@qt.io>2021-09-06 16:13:28 +0000
commit216f11039657ff3a43c7acbdb89166feae62bee9 (patch)
tree4600a39fd7ba0f327ab468c21566a259fb454901 /CMakeLists.txt
parent754ee7e035be4afa60c7f5c344057b9f1b7d0d70 (diff)
Fix mediaplayer QML example's layout and icons
The play control buttons were overlaying the rate seekbar and have wrong layout on both portrait and landscape. Also make sure QtSvg is added to the project because mute/unmute button is an svg image and it's not being loaded properly without the fix. Change-Id: I98e26273ca5a2496d624c378d868ac497dd19741 Reviewed-by: Tor Arne Vestbø <tor.arne.vestbo@qt.io> (cherry picked from commit 671396809fd866e0e3d7793f8fd635b0ad33bed7) Reviewed-by: Assam Boudjelthia <assam.boudjelthia@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3f90e7064..08c092e2b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -11,7 +11,7 @@ project(QtMultimedia
)
find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Core)
-find_package(Qt6 ${PROJECT_VERSION} QUIET CONFIG OPTIONAL_COMPONENTS Gui Network Widgets Quick Qml QuickTest QuickControls2)
+find_package(Qt6 ${PROJECT_VERSION} QUIET CONFIG OPTIONAL_COMPONENTS Gui Network Svg Widgets Quick Qml QuickTest QuickControls2)
if(NOT TARGET Qt::Gui)
message(NOTICE "Skipping the build as the condition \"TARGET Qt::Gui\" is not met.")