summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLars Knoll <lars.knoll@qt.io>2022-04-21 09:24:33 +0200
committerLars Knoll <lars.knoll@qt.io>2022-05-11 08:23:46 +0200
commit82943943820848b437fbc99c405bbb5169e880e1 (patch)
tree65936ec950b526a2865365959a4111c70bb836ea /CMakeLists.txt
parent5f5b32f5b03c2c8a9dfc59cbc1fa82713eb6d259 (diff)
Add the Quick3D.SpatialAudio QML module
Also this has been developed outside of Qt Multimedia so far, but it makes sense to add it here. This does however introduce an optional dependency of this module to qt quick3d. Change-Id: I357505a5832976917414acc07ca0480a635af176 Reviewed-by: Lars Knoll <lars.knoll@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0b32954f3..033d02ec5 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -11,7 +11,7 @@ project(QtMultimedia
)
find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Core)
-find_package(Qt6 ${PROJECT_VERSION} QUIET CONFIG OPTIONAL_COMPONENTS Gui Network Svg Widgets Quick Qml QuickTest QuickControls2)
+find_package(Qt6 ${PROJECT_VERSION} QUIET CONFIG OPTIONAL_COMPONENTS Gui Network Svg Widgets Quick Qml QuickTest QuickControls2 Quick3D)
if(NOT TARGET Qt::Gui)
message(NOTICE "Skipping the build as the condition \"TARGET Qt::Gui\" is not met.")