summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLorn Potter <lorn.potter@gmail.com>2022-06-10 11:42:16 +1000
committerLorn Potter <lorn.potter@gmail.com>2022-07-06 22:26:27 +0000
commit731e6b6f510b01e496860a208d304789aa72fca3 (patch)
treeefb4e39d1f771c114fec4981a15b9277861926ec /CMakeLists.txt
parent289280f33e2881061529f91c33bbfa8910486edb (diff)
wasm: update and fix qwasmaudiodevice
- set min and max sample rates according to AudioContext docs - remove use of EM_ASM to allow better use of multithreading - ensure feature thread is used Fixes: QTBUG-104045 Pick-to: 6.4 Change-Id: Id0bf8905c68f4364abc6f3a9029f75cc5275ff0b Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io> Reviewed-by: Lars Knoll <lars.knoll@gmail.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 033d02ec5..96b2f8cb3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -21,5 +21,10 @@ if(NOT TARGET Qt::Network)
message(NOTICE "Skipping the build as the condition \"TARGET Qt::Network\" is not met.")
return()
endif()
+if(NOT QT_FEATURE_thread)
+ message(NOTICE "Skipping the build as the QT_FEATURE_thread is not met.")
+ return()
+endif()
+
qt_build_repo()