summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2021-05-26 15:00:00 +0200
committerLars Knoll <lars.knoll@qt.io>2021-05-27 10:02:58 +0200
commit7f85d636f169113578583b8b6e7f298ab962f852 (patch)
tree9e616c42100f85b60b267849e959a97421369c90 /CMakeLists.txt
parent00e68708e560250f43e3660e9190cd6c0d6b9d7a (diff)
CMake: Remove usage of old compatibility CMake API
Task-number: QTBUG-86815 Change-Id: I576c52bfa41db5b52defd39615d944a05953b540 Reviewed-by: Lars Knoll <lars.knoll@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2d128888d..df97b285f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -10,10 +10,11 @@ project(QtMultimedia
LANGUAGES CXX C
)
-# special case begin
+# Make sure we only use latest private CMake API, aka no compatibility wrappers.
+set(QT_NO_INTERNAL_COMPATIBILITY_FUNCTIONS TRUE)
+
find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Core)
find_package(Qt6 ${PROJECT_VERSION} QUIET CONFIG OPTIONAL_COMPONENTS Gui Network Widgets Quick Qml OpenGL OpenGLWidgets QuickTest)
-# special case end
if(NOT TARGET Qt::Gui)
message(NOTICE "Skipping the build as the condition \"TARGET Qt::Gui\" is not met.")