summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLars Knoll <lars.knoll@qt.io>2021-05-28 12:27:03 +0200
committerLars Knoll <lars.knoll@qt.io>2021-05-28 14:29:08 +0200
commita7621a6db7bdbe514be825cbc2952d50e328bab4 (patch)
tree6df8d5ed2468422e3bc441c9d154e15874a386ab /CMakeLists.txt
parentdb32cdeb54c6339be908a539e129792d9e823d30 (diff)
Remove the dependency on the QtOpenGL module
It's not being used anymore. Change-Id: Ic6964e44845f3eb22265a4e975f4b5466055fb9e Reviewed-by: Doris Verria <doris.verria@qt.io> Reviewed-by: Volker Hilsheimer <volker.hilsheimer@qt.io> Reviewed-by: André de la Rocha <andre.rocha@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index df97b285f..bbdede053 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -14,7 +14,7 @@ project(QtMultimedia
set(QT_NO_INTERNAL_COMPATIBILITY_FUNCTIONS TRUE)
find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Core)
-find_package(Qt6 ${PROJECT_VERSION} QUIET CONFIG OPTIONAL_COMPONENTS Gui Network Widgets Quick Qml OpenGL OpenGLWidgets QuickTest)
+find_package(Qt6 ${PROJECT_VERSION} QUIET CONFIG OPTIONAL_COMPONENTS Gui Network Widgets Quick Qml QuickTest)
if(NOT TARGET Qt::Gui)
message(NOTICE "Skipping the build as the condition \"TARGET Qt::Gui\" is not met.")
@@ -24,4 +24,5 @@ if(NOT TARGET Qt::Network)
message(NOTICE "Skipping the build as the condition \"TARGET Qt::Network\" is not met.")
return()
endif()
+
qt_build_repo()