summaryrefslogtreecommitdiffstats
path: root/examples/multimedia/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2021-12-14 18:00:34 +0100
committerAlexandru Croitor <alexandru.croitor@qt.io>2021-12-15 12:56:16 +0100
commit11d810823522c9d850e1db96c0027f7ba50e89d6 (patch)
tree16818c22fef8ae6e7939c161bfcd5de3098ae14e /examples/multimedia/CMakeLists.txt
parent4d447421d75be3ede9e9a0fd70d4220a2e1b5bf5 (diff)
Switch examples to build as isolated sub-builds
Pick-to: 6.2 6.3 Task-number: QTBUG-90820 Change-Id: I7b3fe87c4dc9b3ed71c97598d07c592c7e707db8 Reviewed-by: Alexey Edelev <alexey.edelev@qt.io>
Diffstat (limited to 'examples/multimedia/CMakeLists.txt')
-rw-r--r--examples/multimedia/CMakeLists.txt16
1 files changed, 8 insertions, 8 deletions
diff --git a/examples/multimedia/CMakeLists.txt b/examples/multimedia/CMakeLists.txt
index 3ae1d06e9..40c83308e 100644
--- a/examples/multimedia/CMakeLists.txt
+++ b/examples/multimedia/CMakeLists.txt
@@ -1,19 +1,19 @@
# Generated from multimedia.pro.
-add_subdirectory(audiodecoder)
+qt_internal_add_example(audiodecoder)
if(NOT ANDROID AND NOT IOS)
- add_subdirectory(devices)
+ qt_internal_add_example(devices)
endif()
if(TARGET Qt::Widgets)
- add_subdirectory(spectrum)
- add_subdirectory(audiorecorder)
+ qt_internal_add_example(spectrum)
+ qt_internal_add_example(audiorecorder)
if(NOT ANDROID AND NOT IOS)
- add_subdirectory(audiodevices)
+ qt_internal_add_example(audiodevices)
endif()
- add_subdirectory(audiosource)
- add_subdirectory(audiooutput)
+ qt_internal_add_example(audiosource)
+ qt_internal_add_example(audiooutput)
endif()
if(TARGET Qt::Quick)
- add_subdirectory(declarative-camera)
+ qt_internal_add_example(declarative-camera)
add_subdirectory(video)
endif()