summaryrefslogtreecommitdiffstats
path: root/examples/multimedia/CMakeLists.txt
diff options
context:
space:
mode:
authorAssam Boudjelthia <assam.boudjelthia@qt.io>2021-09-22 13:51:31 +0300
committerAssam Boudjelthia <assam.boudjelthia@qt.io>2021-09-22 18:24:37 +0300
commit1c8a2dbcd8ae26209cfed2fce288e6511d8c3f72 (patch)
tree50c5ee1f4e935625e54b4a9be999bff555633672 /examples/multimedia/CMakeLists.txt
parentc931241cdac1f908300dd27b82d9bf4ffdbecc41 (diff)
Exclude example from Android and iOS the right way
Don't add_subdirectory(devices) for Android and iOS, instead of throwing a warning. Pick-to: 6.2 Change-Id: Iaa4300d3ad875557f11504f80d0224d72debe2f9 Reviewed-by: Lars Knoll <lars.knoll@qt.io>
Diffstat (limited to 'examples/multimedia/CMakeLists.txt')
-rw-r--r--examples/multimedia/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/examples/multimedia/CMakeLists.txt b/examples/multimedia/CMakeLists.txt
index ab7280862..3ae1d06e9 100644
--- a/examples/multimedia/CMakeLists.txt
+++ b/examples/multimedia/CMakeLists.txt
@@ -1,7 +1,9 @@
# Generated from multimedia.pro.
add_subdirectory(audiodecoder)
-add_subdirectory(devices)
+if(NOT ANDROID AND NOT IOS)
+ add_subdirectory(devices)
+endif()
if(TARGET Qt::Widgets)
add_subdirectory(spectrum)
add_subdirectory(audiorecorder)