summaryrefslogtreecommitdiffstats
path: root/examples/multimedia/video/qmlvideo/CMakeLists.txt
diff options
context:
space:
mode:
authorAssam Boudjelthia <assam.boudjelthia@qt.io>2021-05-11 13:28:31 +0300
committerLars Knoll <lars.knoll@qt.io>2021-05-12 10:01:26 +0000
commitec2760e61d7e9a22578d7957f7e3317e3295ab2c (patch)
tree159c9cbd2939696ff09069455fc5f99d7a760590 /examples/multimedia/video/qmlvideo/CMakeLists.txt
parent154fd5f6a95849965af47c540e22e7d94020b221 (diff)
Remove dependency on qtandroidextras
Remove use of Qt Android Extras APIs. Change-Id: I020a3966b284f19d7f0c4b313543bb4c4820f039 Reviewed-by: Lars Knoll <lars.knoll@qt.io>
Diffstat (limited to 'examples/multimedia/video/qmlvideo/CMakeLists.txt')
-rw-r--r--examples/multimedia/video/qmlvideo/CMakeLists.txt10
1 files changed, 0 insertions, 10 deletions
diff --git a/examples/multimedia/video/qmlvideo/CMakeLists.txt b/examples/multimedia/video/qmlvideo/CMakeLists.txt
index b5f78960d..3aeab9731 100644
--- a/examples/multimedia/video/qmlvideo/CMakeLists.txt
+++ b/examples/multimedia/video/qmlvideo/CMakeLists.txt
@@ -150,16 +150,6 @@ qt6_add_resources(qmlvideo "performancemonitordeclarative"
${performancemonitordeclarative_resource_files}
)
-if(ANDROID AND TARGET Qt::AndroidExtras)
- target_compile_definitions(qmlvideo PUBLIC
- REQUEST_PERMISSIONS_ON_ANDROID
- )
-
- target_link_libraries(qmlvideo PUBLIC
- Qt::AndroidExtras
- )
-endif()
-
install(TARGETS qmlvideo
RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"