summaryrefslogtreecommitdiffstats
path: root/examples/multimedia/video/qmlvideofilter_opencl/CMakeLists.txt
diff options
context:
space:
mode:
authorLars Knoll <lars.knoll@qt.io>2021-04-12 09:18:08 +0200
committerLars Knoll <lars.knoll@qt.io>2021-04-14 14:00:59 +0000
commit50309974fd82f52877f96ee3cfffafa24600d397 (patch)
tree92440f5e3fb01f2007ee4944d6c7ddaa069e679c /examples/multimedia/video/qmlvideofilter_opencl/CMakeLists.txt
parent389c1e3bd122b7bb40b5834bf164a69eecbb6635 (diff)
Remove QAbstractVideoFilter
The API covers a relatively rare use case, and is far from ideal, as it doesn't cooperate very well with HW accerlerated rendering. Since QVideoFrame and the QML VideoOutput item offer the option to get a texture for the frame, it's probably better to use that as the basis for further processing. Change-Id: I89deb915f660312fb3a83b066a5371f5454346da Reviewed-by: Doris Verria <doris.verria@qt.io> Reviewed-by: Lars Knoll <lars.knoll@qt.io>
Diffstat (limited to 'examples/multimedia/video/qmlvideofilter_opencl/CMakeLists.txt')
-rw-r--r--examples/multimedia/video/qmlvideofilter_opencl/CMakeLists.txt74
1 files changed, 0 insertions, 74 deletions
diff --git a/examples/multimedia/video/qmlvideofilter_opencl/CMakeLists.txt b/examples/multimedia/video/qmlvideofilter_opencl/CMakeLists.txt
deleted file mode 100644
index a3c1d6a19..000000000
--- a/examples/multimedia/video/qmlvideofilter_opencl/CMakeLists.txt
+++ /dev/null
@@ -1,74 +0,0 @@
-# Generated from qmlvideofilter_opencl.pro.
-
-cmake_minimum_required(VERSION 3.14)
-project(qmlvideofilter_opencl LANGUAGES CXX)
-
-set(CMAKE_INCLUDE_CURRENT_DIR ON)
-
-set(CMAKE_AUTOMOC ON)
-set(CMAKE_AUTORCC ON)
-set(CMAKE_AUTOUIC ON)
-
-if(NOT DEFINED INSTALL_EXAMPLESDIR)
- set(INSTALL_EXAMPLESDIR "examples")
-endif()
-
-set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/multimedia/video/qmlvideofilter_opencl")
-
-find_package(Qt6 COMPONENTS Core)
-find_package(Qt6 COMPONENTS Gui)
-find_package(Qt6 COMPONENTS Quick)
-find_package(Qt6 COMPONENTS Multimedia)
-
-qt_add_executable(qmlvideofilter_opencl
- main.cpp
- rgbframehelper.h
-)
-set_target_properties(qmlvideofilter_opencl PROPERTIES
- WIN32_EXECUTABLE TRUE
- MACOSX_BUNDLE TRUE
-)
-target_link_libraries(qmlvideofilter_opencl PUBLIC
- Qt::Core
- Qt::Gui
- Qt::Multimedia
- Qt::Quick
-)
-
-
-# Resources:
-set(qmlvideofilter_opencl_resource_files
- "main.qml"
-)
-
-qt6_add_resources(qmlvideofilter_opencl "qmlvideofilter_opencl"
- PREFIX
- "/"
- FILES
- ${qmlvideofilter_opencl_resource_files}
-)
-
-if(MACOS)
- target_link_libraries(qmlvideofilter_opencl PUBLIC
- "-framework OpenCL"
- )
-endif()
-
-if(UNIX AND NOT MACOS)
- target_link_libraries(qmlvideofilter_opencl PUBLIC
- OpenCL
- )
-endif()
-
-if(WIN32 AND NOT WINRT)
- target_link_libraries(qmlvideofilter_opencl PUBLIC
- OpenCL
- opengl32
- )
-endif()
-
-install(TARGETS qmlvideofilter_opencl
- RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
- BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
- LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
-)