summaryrefslogtreecommitdiffstats
path: root/examples/multimedia/video/recorder/CMakeLists.txt
diff options
context:
space:
mode:
authorDoris Verria <doris.verria@qt.io>2021-08-18 20:00:08 +0200
committerQt Cherry-pick Bot <cherrypick_bot@qt-project.org>2021-08-19 11:05:01 +0000
commiteffba6b6bca7efbc2bacd5a6b57b5a097792c41a (patch)
tree8df97a10bdae7d555e328ebf60ac94a25948dc7f /examples/multimedia/video/recorder/CMakeLists.txt
parentdd49b60f636476dad8946ed91364dbe7d26e8527 (diff)
Recorder example: Build as app bundle on macOS/iOS
Add an Info.plist file for camera and microphone usage too. Change-Id: Ia1fafec2f01dcb1c3d85ce6efcc642fc9d5216b8 Reviewed-by: Piotr Srebrny <piotr.srebrny@qt.io> Reviewed-by: Lars Knoll <lars.knoll@qt.io> (cherry picked from commit 1b7f5a052dd4972e19748d3831b60788ff56aadb) Reviewed-by: Qt Cherry-pick Bot <cherrypick_bot@qt-project.org>
Diffstat (limited to 'examples/multimedia/video/recorder/CMakeLists.txt')
-rw-r--r--examples/multimedia/video/recorder/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/examples/multimedia/video/recorder/CMakeLists.txt b/examples/multimedia/video/recorder/CMakeLists.txt
index b01a23ca3..e885d0abe 100644
--- a/examples/multimedia/video/recorder/CMakeLists.txt
+++ b/examples/multimedia/video/recorder/CMakeLists.txt
@@ -27,3 +27,8 @@ target_compile_definitions(recorder
PRIVATE $<$<OR:$<CONFIG:Debug>,$<CONFIG:RelWithDebInfo>>:QT_QML_DEBUG>)
target_link_libraries(recorder
PRIVATE Qt6::Core Qt6::Quick Qt6::Multimedia)
+
+set_target_properties(recorder PROPERTIES
+ MACOSX_BUNDLE TRUE
+ MACOSX_BUNDLE_INFO_PLIST ${CMAKE_CURRENT_SOURCE_DIR}/Info.plist.in
+)