summaryrefslogtreecommitdiffstats
path: root/examples/multimedia/video/recorder/CMakeLists.txt
diff options
context:
space:
mode:
authorDoris Verria <doris.verria@qt.io>2021-12-15 23:40:17 +0100
committerDoris Verria <doris.verria@qt.io>2021-12-17 12:45:41 +0100
commit767315b2049f0685f12de3418c658313851e8c0f (patch)
tree2e754aac8e89da7dab5aeb10d8c9b1bcef5bde6e /examples/multimedia/video/recorder/CMakeLists.txt
parent77096edebd7dda161db42b92a5b3bc41f9c69740 (diff)
Multimedia examples: Add camera and audio input entitlements
Apple needs apps to specify proper entitlements in order to grant the executable permissions to use services like camera and microphone. The multimedia examples using microphone and camera were sometimes crashing because of missing entitlements. To fix, add an entitlement file to all examples using these services, and add a post-build command to codesign the executables with the specified entitlements. Task-number: QTBUG-98419 Pick-to: 6.3 6.2 Change-Id: I6a578def1f6a41b4d106ee49c0c32fad304ef3cb Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'examples/multimedia/video/recorder/CMakeLists.txt')
-rw-r--r--examples/multimedia/video/recorder/CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/examples/multimedia/video/recorder/CMakeLists.txt b/examples/multimedia/video/recorder/CMakeLists.txt
index e885d0abe..a0067cd11 100644
--- a/examples/multimedia/video/recorder/CMakeLists.txt
+++ b/examples/multimedia/video/recorder/CMakeLists.txt
@@ -31,4 +31,15 @@ target_link_libraries(recorder
set_target_properties(recorder PROPERTIES
MACOSX_BUNDLE TRUE
MACOSX_BUNDLE_INFO_PLIST ${CMAKE_CURRENT_SOURCE_DIR}/Info.plist.in
+ XCODE_ATTRIBUTE_CODE_SIGN_ENTITLEMENTS
+ "${CMAKE_CURRENT_LIST_DIR}/recorder.entitlements"
)
+
+if(APPLE AND NOT IOS)
+ if(NOT CMAKE_GENERATOR STREQUAL "Xcode")
+ add_custom_command(TARGET recorder
+ POST_BUILD
+ COMMAND codesign --sign - --entitlements ${CMAKE_CURRENT_SOURCE_DIR}/recorder.entitlements ${CMAKE_CURRENT_BINARY_DIR}/recorder.app
+ )
+ endif()
+endif()