summaryrefslogtreecommitdiffstats
path: root/examples/multimedia/video/recorder/CMakeLists.txt
diff options
context:
space:
mode:
authorDoris Verria <doris.verria@qt.io>2022-03-16 14:07:59 +0100
committerQt Cherry-pick Bot <cherrypick_bot@qt-project.org>2022-03-17 21:17:00 +0000
commit0790918ef8d0dc863aefeaa190250ba948a26904 (patch)
treee3858c2b619fda2f7efb68f277f83879a9367a43 /examples/multimedia/video/recorder/CMakeLists.txt
parentfbac328fe9ff787049a779f93f51ed5bb35e5093 (diff)
Remove the code-signing step from examples
Codesigning with entitlements is not needed unless the hardened-runtime option is enabled, so we can remove this post-build step. Fixes: QTBUG-101719 Change-Id: I35181220dbe4ef6b59072dcd3e76f066ab85db60 Reviewed-by: Lars Knoll <lars.knoll@qt.io> Reviewed-by: Tor Arne Vestbø <tor.arne.vestbo@qt.io> (cherry picked from commit fa8e9a39bfbffaa23200a88bb700e86490389183) Reviewed-by: Qt Cherry-pick Bot <cherrypick_bot@qt-project.org>
Diffstat (limited to 'examples/multimedia/video/recorder/CMakeLists.txt')
-rw-r--r--examples/multimedia/video/recorder/CMakeLists.txt11
1 files changed, 0 insertions, 11 deletions
diff --git a/examples/multimedia/video/recorder/CMakeLists.txt b/examples/multimedia/video/recorder/CMakeLists.txt
index 63036e7b2..33331b329 100644
--- a/examples/multimedia/video/recorder/CMakeLists.txt
+++ b/examples/multimedia/video/recorder/CMakeLists.txt
@@ -56,19 +56,8 @@ target_link_libraries(recorder
set_target_properties(recorder PROPERTIES
MACOSX_BUNDLE TRUE
MACOSX_BUNDLE_INFO_PLIST ${CMAKE_CURRENT_SOURCE_DIR}/Info.plist.in
- XCODE_ATTRIBUTE_CODE_SIGN_ENTITLEMENTS
- "${CMAKE_CURRENT_LIST_DIR}/recorder.entitlements"
)
-if(APPLE AND NOT IOS)
- if(NOT CMAKE_GENERATOR STREQUAL "Xcode")
- add_custom_command(TARGET recorder
- POST_BUILD
- COMMAND codesign --sign - --entitlements ${CMAKE_CURRENT_SOURCE_DIR}/recorder.entitlements ${CMAKE_CURRENT_BINARY_DIR}/recorder.app
- )
- endif()
-endif()
-
install(TARGETS recorder
RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"