summaryrefslogtreecommitdiffstats
path: root/src/multimedia/CMakeLists.txt
diff options
context:
space:
mode:
authorLars Knoll <lars.knoll@qt.io>2021-04-12 09:18:08 +0200
committerLars Knoll <lars.knoll@qt.io>2021-04-14 14:00:59 +0000
commit50309974fd82f52877f96ee3cfffafa24600d397 (patch)
tree92440f5e3fb01f2007ee4944d6c7ddaa069e679c /src/multimedia/CMakeLists.txt
parent389c1e3bd122b7bb40b5834bf164a69eecbb6635 (diff)
Remove QAbstractVideoFilter
The API covers a relatively rare use case, and is far from ideal, as it doesn't cooperate very well with HW accerlerated rendering. Since QVideoFrame and the QML VideoOutput item offer the option to get a texture for the frame, it's probably better to use that as the basis for further processing. Change-Id: I89deb915f660312fb3a83b066a5371f5454346da Reviewed-by: Doris Verria <doris.verria@qt.io> Reviewed-by: Lars Knoll <lars.knoll@qt.io>
Diffstat (limited to 'src/multimedia/CMakeLists.txt')
-rw-r--r--src/multimedia/CMakeLists.txt1
1 files changed, 0 insertions, 1 deletions
diff --git a/src/multimedia/CMakeLists.txt b/src/multimedia/CMakeLists.txt
index 0de527d4b..f1f8a27a3 100644
--- a/src/multimedia/CMakeLists.txt
+++ b/src/multimedia/CMakeLists.txt
@@ -62,7 +62,6 @@ qt_internal_add_module(Multimedia
recording/qmediaencodersettings.cpp recording/qmediaencodersettings.h
recording/qmediarecorder.cpp recording/qmediarecorder.h recording/qmediarecorder_p.h
video/qabstractvideobuffer.cpp video/qabstractvideobuffer_p.h
- video/qabstractvideofilter.cpp video/qabstractvideofilter.h
video/qimagevideobuffer.cpp video/qimagevideobuffer_p.h
video/qmemoryvideobuffer.cpp video/qmemoryvideobuffer_p.h
video/qvideoframe.cpp video/qvideoframe.h