summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 033d02ec5..96b2f8cb3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -21,5 +21,10 @@ if(NOT TARGET Qt::Network)
message(NOTICE "Skipping the build as the condition \"TARGET Qt::Network\" is not met.")
return()
endif()
+if(NOT QT_FEATURE_thread)
+ message(NOTICE "Skipping the build as the QT_FEATURE_thread is not met.")
+ return()
+endif()
+
qt_build_repo()