summaryrefslogtreecommitdiffstats
path: root/examples/multimedia/devices/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/multimedia/devices/CMakeLists.txt')
-rw-r--r--examples/multimedia/devices/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/examples/multimedia/devices/CMakeLists.txt b/examples/multimedia/devices/CMakeLists.txt
index d75b4f23f..c7e038bb5 100644
--- a/examples/multimedia/devices/CMakeLists.txt
+++ b/examples/multimedia/devices/CMakeLists.txt
@@ -3,6 +3,10 @@
cmake_minimum_required(VERSION 3.16)
project(devices LANGUAGES CXX)
+if(ANDROID OR IOS)
+ message(FATAL_ERROR "This is a commandline tool that is not supported on mobile platforms")
+endif()
+
set(CMAKE_INCLUDE_CURRENT_DIR ON)
set(CMAKE_AUTOMOC ON)