summaryrefslogtreecommitdiffstats
path: root/examples/oauth/twittertimeline/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2020-10-26 17:25:39 +0100
committerAlexandru Croitor <alexandru.croitor@qt.io>2020-11-07 22:07:10 +0100
commitafe618ecdc534c8b364cd82ab37c387dc91637e0 (patch)
treed81bb53c684049f6112e2edeec3f004e490eeed9 /examples/oauth/twittertimeline/CMakeLists.txt
parent44686d4985fe5ed1aedb22939a1d556eaa413ce2 (diff)
CMake: Regenerate examples to set the WIN32_EXECUTABLE property
As well as the MACOSX_BUNDLE properties as necessary. Task-number: QTBUG-87664 Change-Id: I530ff4616167f3a233c136800b466992d4306cf0 Reviewed-by: Joerg Bornemann <joerg.bornemann@qt.io>
Diffstat (limited to 'examples/oauth/twittertimeline/CMakeLists.txt')
-rw-r--r--examples/oauth/twittertimeline/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/examples/oauth/twittertimeline/CMakeLists.txt b/examples/oauth/twittertimeline/CMakeLists.txt
index c76d592..e4b35d9 100644
--- a/examples/oauth/twittertimeline/CMakeLists.txt
+++ b/examples/oauth/twittertimeline/CMakeLists.txt
@@ -26,6 +26,10 @@ qt_add_executable(twittertimeline
twitterdialog.ui
twittertimelinemodel.cpp twittertimelinemodel.h
)
+set_target_properties(twittertimeline PROPERTIES
+ WIN32_EXECUTABLE TRUE
+ MACOSX_BUNDLE FALSE
+)
target_link_libraries(twittertimeline PUBLIC
Qt::Core
Qt::Network