summaryrefslogtreecommitdiffstats
path: root/examples/oauth/twittertimeline/CMakeLists.txt
diff options
context:
space:
mode:
authorLeander Beernaert <leander.beernaert@qt.io>2019-06-03 13:11:37 +0200
committerLeander Beernaert <leander.beernaert@qt.io>2019-06-03 14:45:36 +0000
commit5399e01c18eea5c1d59c08fbdba84ae88c337982 (patch)
treea6453e837366586bf4e912376c3ba3e87d304952 /examples/oauth/twittertimeline/CMakeLists.txt
parent8bc6feb36a471006cfa4b62189edc3d7fd67bf78 (diff)
CMake Port for QtNetworkAuth
Convert the QtNetworkAuth project to be compatible with the cmake build system. Includes tests and examples. Added header guard to twitter.h to work with CMake's moc setup. Change-Id: I0762e0b53f4e3194c969655e4c3deae21768b327 Reviewed-by: Simon Hausmann <simon.hausmann@qt.io> Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'examples/oauth/twittertimeline/CMakeLists.txt')
-rw-r--r--examples/oauth/twittertimeline/CMakeLists.txt25
1 files changed, 25 insertions, 0 deletions
diff --git a/examples/oauth/twittertimeline/CMakeLists.txt b/examples/oauth/twittertimeline/CMakeLists.txt
new file mode 100644
index 0000000..c7654be
--- /dev/null
+++ b/examples/oauth/twittertimeline/CMakeLists.txt
@@ -0,0 +1,25 @@
+# Generated from twittertimeline.pro.
+
+#####################################################################
+## twittertimeline Binary:
+#####################################################################
+
+add_qt_executable(twittertimeline
+ GUI
+ OUTPUT_DIRECTORY "${INSTALL_EXAMPLESDIR}/oauth/twittertimeline"
+ INSTALL_DIRECTORY "${INSTALL_EXAMPLESDIR}/oauth/twittertimeline"
+ SOURCES
+ main.cpp
+ twitter.cpp twitter.h
+ twitterdialog.ui
+ twittertimelinemodel.cpp twittertimelinemodel.h
+ PUBLIC_LIBRARIES
+ Qt::Network
+ Qt::NetworkAuth
+ Qt::Widgets
+ ENABLE_AUTOGEN_TOOLS
+ uic
+)
+
+#### Keys ignored in scope 1:.:.:twittertimeline.pro:<TRUE>:
+# CONFIG = "-app_bundle"