summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJannis Voelker <jannis.voelker@basyskom.com>2020-05-06 13:41:46 +0200
committerJannis Voelker <jannis.voelker@basyskom.com>2020-06-04 09:21:39 +0200
commit119bbeb00b96ed628d4dff32dfea6fee09d74abf (patch)
treee877ec40469aeedba7527a4afdd4bfc63c1e1119 /CMakeLists.txt
parent762126c13026d4ae7cdbd27ad621ef43e155279c (diff)
Add CMake support for building Qt OPC UA
Change-Id: I1cf9c7f4914a665d7a057950eb6528929034e039 Reviewed-by: Frank Meerkoetter <frank.meerkoetter@basyskom.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt26
1 files changed, 26 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..3a1c309
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,26 @@
+# Generated from qtopcua.pro.
+
+cmake_minimum_required(VERSION 3.15.0)
+
+include(.cmake.conf)
+project(QtOpcUa
+ VERSION "${QT_REPO_MODULE_VERSION}"
+ DESCRIPTION "Qt OpcUa Libraries"
+ HOMEPAGE_URL "https://qt.io/"
+ LANGUAGES CXX C
+)
+
+# special case begin
+find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Core Network)
+find_package(Qt6 ${PROJECT_VERSION} CONFIG OPTIONAL_COMPONENTS Gui Quick QuickTest Widgets)
+# special case end
+
+if(QNX)
+ message(NOTICE "Skipping the build as the condition \"NOT QNX\" is not met.")
+ return()
+endif()
+if(WASM)
+ message(NOTICE "Skipping the build as the condition \"NOT WASM\" is not met.")
+ return()
+endif()
+qt_build_repo()