summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJannis Voelker <jannis.voelker@basyskom.com>2020-08-06 15:26:02 +0200
committerAlexandru Croitor <alexandru.croitor@qt.io>2020-08-07 16:36:35 +0200
commit936cc2b930186ed9803a19cd55dd2eaa732cab51 (patch)
tree071deed4acbf2582719bfad72fe6c6a947c92ba2 /CMakeLists.txt
parent811deee41d99b7c619bd0aae33c3191b4c07bac3 (diff)
CMake: Fix CMake build for open62541
Fix -Wno flags to be assigned to the correct property as a list of values. Remove unnecessary Q_DECLARE_METATYPE because the type is already registered automatically somewhere. Fix standalone example using private API and not having the C language enabled. Remove optimization flags for open62541.c like the qmake project does, to circumvent some miscompilation on MSVC which makes the test server not start, and thus hangs CI integrations. We do this for the test and example, but not the plugin, just to be safe for now. It's done by a public OpcUA function called qt_opcua_disable_optimizations_in_current_dir. Regenerate some projects that used old APIs. Task-number: QTBUG-85939 Change-Id: I2aea0e64371e99da3e2330f477c754728a8a5dd5 Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org> Reviewed-by: Jannis Völker <jannis.voelker@basyskom.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3a1c309..a301534 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -15,6 +15,11 @@ find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Co
find_package(Qt6 ${PROJECT_VERSION} CONFIG OPTIONAL_COMPONENTS Gui Quick QuickTest Widgets)
# special case end
+# special case begin
+# Needed for qt_opcua_disable_optimizations_in_current_dir.
+include(src/opcua/Qt6OpcUaMacros.cmake)
+# special case end
+
if(QNX)
message(NOTICE "Skipping the build as the condition \"NOT QNX\" is not met.")
return()