summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJoerg Bornemann <joerg.bornemann@qt.io>2021-05-19 15:33:47 +0200
committerJoerg Bornemann <joerg.bornemann@qt.io>2021-05-20 11:42:43 +0200
commitac476a4530c16e172d2ac2844c4451dcccc75d0b (patch)
tree10a11f1c5129cb0a87529d52f2bb2db0b2108b13 /CMakeLists.txt
parent2de19b433b81b4a69a7815ebec5294d03b74d662 (diff)
Use fixed qt_add_resource BASE argument
Pick-to: 6.1 Task-number: QTBUG-86726 Change-Id: I8372086c40043a6bd1d306b6bfb711e96ddc7cb7 Reviewed-by: Frank Meerkoetter <frank.meerkoetter@basyskom.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a301534..91cbf10 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -10,6 +10,9 @@ project(QtOpcUa
LANGUAGES CXX C
)
+# Make sure we use the fixed BASE argument of qt_add_resource.
+set(QT_USE_FIXED_QT_ADD_RESOURCE_BASE TRUE)
+
# special case begin
find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Core Network)
find_package(Qt6 ${PROJECT_VERSION} CONFIG OPTIONAL_COMPONENTS Gui Quick QuickTest Widgets)