summaryrefslogtreecommitdiffstats
path: root/examples/positioning/satelliteinfo/CMakeLists.txt
diff options
context:
space:
mode:
authorIvan Solovev <ivan.solovev@qt.io>2021-03-16 13:08:34 +0100
committerIvan Solovev <ivan.solovev@qt.io>2021-03-23 10:44:43 +0100
commit2c962c3251a0e8c3375e8de628622cf8f0154f83 (patch)
tree644c50b5f84d097a76611654d5448c54b0b8a164 /examples/positioning/satelliteinfo/CMakeLists.txt
parentebe3a8c054ff82f255a5414d51d13b2aa01bafaa (diff)
QtPositioning: improve satelliteinfo example
Register model for QML using QML_ELEMENT. Improve the example documentation. Task-number: QTBUG-89855 Change-Id: I88abccecbba446332501ddb787cf4bbb8d0d8058 Reviewed-by: Leena Miettinen <riitta-leena.miettinen@qt.io> Reviewed-by: Alex Blasche <alexander.blasche@qt.io>
Diffstat (limited to 'examples/positioning/satelliteinfo/CMakeLists.txt')
-rw-r--r--examples/positioning/satelliteinfo/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/examples/positioning/satelliteinfo/CMakeLists.txt b/examples/positioning/satelliteinfo/CMakeLists.txt
index 9e0bdebf..092bf290 100644
--- a/examples/positioning/satelliteinfo/CMakeLists.txt
+++ b/examples/positioning/satelliteinfo/CMakeLists.txt
@@ -53,3 +53,9 @@ install(TARGETS satelliteinfo
BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
)
+
+set_target_properties(satelliteinfo PROPERTIES
+ QT_QML_MODULE_VERSION 1.0
+ QT_QML_MODULE_URI Local
+)
+qt6_qml_type_registration(satelliteinfo)