summaryrefslogtreecommitdiffstats
path: root/examples/mobile/quickhit/plugins/LevelOne/debian
diff options
context:
space:
mode:
Diffstat (limited to 'examples/mobile/quickhit/plugins/LevelOne/debian')
-rw-r--r--examples/mobile/quickhit/plugins/LevelOne/debian/changelog11
-rw-r--r--examples/mobile/quickhit/plugins/LevelOne/debian/compat1
-rw-r--r--examples/mobile/quickhit/plugins/LevelOne/debian/control11
-rw-r--r--examples/mobile/quickhit/plugins/LevelOne/debian/copyright8
-rw-r--r--examples/mobile/quickhit/plugins/LevelOne/debian/dirs2
-rw-r--r--examples/mobile/quickhit/plugins/LevelOne/debian/postinst5
-rw-r--r--examples/mobile/quickhit/plugins/LevelOne/debian/rules91
7 files changed, 129 insertions, 0 deletions
diff --git a/examples/mobile/quickhit/plugins/LevelOne/debian/changelog b/examples/mobile/quickhit/plugins/LevelOne/debian/changelog
new file mode 100644
index 00000000..de7ac989
--- /dev/null
+++ b/examples/mobile/quickhit/plugins/LevelOne/debian/changelog
@@ -0,0 +1,11 @@
+levelone (1.1.0) unstable; urgency=low
+
+ * Final graphics
+
+ -- Antonio Aloisio <antonio.aloisio@nokia.com> Wed, 5 Jan 2011 10:05:04 +0200
+
+levelone (1.0.0) unstable; urgency=low
+
+ * First version
+
+ -- Antonio Aloisio <antonio.aloisio@nokia.com> Tue, 19 Oct 2010 10:05:04 +0200
diff --git a/examples/mobile/quickhit/plugins/LevelOne/debian/compat b/examples/mobile/quickhit/plugins/LevelOne/debian/compat
new file mode 100644
index 00000000..7f8f011e
--- /dev/null
+++ b/examples/mobile/quickhit/plugins/LevelOne/debian/compat
@@ -0,0 +1 @@
+7
diff --git a/examples/mobile/quickhit/plugins/LevelOne/debian/control b/examples/mobile/quickhit/plugins/LevelOne/debian/control
new file mode 100644
index 00000000..c46afefb
--- /dev/null
+++ b/examples/mobile/quickhit/plugins/LevelOne/debian/control
@@ -0,0 +1,11 @@
+Source: levelone
+Section: user/games
+Priority: extra
+Maintainer: Antonio Aloisio <antonio.aloisio@nokia.com>
+Standards-Version: 3.7.2
+
+Package: levelone
+Architecture: any
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Description: QuickHit - LevelOne
+ QuickHit - LevelOne
diff --git a/examples/mobile/quickhit/plugins/LevelOne/debian/copyright b/examples/mobile/quickhit/plugins/LevelOne/debian/copyright
new file mode 100644
index 00000000..fb9e5a8e
--- /dev/null
+++ b/examples/mobile/quickhit/plugins/LevelOne/debian/copyright
@@ -0,0 +1,8 @@
+This is qmultiwinexample, written and maintained by Forum Nokia Antonio Aloisio <antonio.aloisio@nokia.com>
+on Tue, 19 Oct 2010 10:05:04 +0200
+
+
+Copyright Holder: Nokia (c) 2010
+
+License:
+
diff --git a/examples/mobile/quickhit/plugins/LevelOne/debian/dirs b/examples/mobile/quickhit/plugins/LevelOne/debian/dirs
new file mode 100644
index 00000000..80507f10
--- /dev/null
+++ b/examples/mobile/quickhit/plugins/LevelOne/debian/dirs
@@ -0,0 +1,2 @@
+usr/bin
+usr/share/applications/hildon
diff --git a/examples/mobile/quickhit/plugins/LevelOne/debian/postinst b/examples/mobile/quickhit/plugins/LevelOne/debian/postinst
new file mode 100644
index 00000000..79fb6ddd
--- /dev/null
+++ b/examples/mobile/quickhit/plugins/LevelOne/debian/postinst
@@ -0,0 +1,5 @@
+#!/bin/sh -e
+
+gtk-update-icon-cache -f /usr/share/icons/hicolor
+
+exit 0
diff --git a/examples/mobile/quickhit/plugins/LevelOne/debian/rules b/examples/mobile/quickhit/plugins/LevelOne/debian/rules
new file mode 100644
index 00000000..53a1d2ea
--- /dev/null
+++ b/examples/mobile/quickhit/plugins/LevelOne/debian/rules
@@ -0,0 +1,91 @@
+#!/usr/bin/make -f
+# -*- makefile -*-
+# Sample debian/rules that uses debhelper.
+# This file was originally written by Joey Hess and Craig Small.
+# As a special exception, when this file is copied by dh-make into a
+# dh-make output file, you may use that output file without restriction.
+# This special exception was added by Craig Small in version 0.37 of dh-make.
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+
+APPNAME := levelone
+
+
+configure: configure-stamp
+configure-stamp:
+ dh_testdir
+ # Add here commands to configure the package.
+
+ touch configure-stamp
+
+
+build: build-stamp
+
+build-stamp: configure-stamp
+ dh_testdir
+
+ # Add here commands to compile the package.
+ $(MAKE)
+ #docbook-to-man debian/$(APPNAME).sgml > $(APPNAME).1
+
+ touch $@
+
+clean:
+ dh_testdir
+ dh_testroot
+ rm -f build-stamp configure-stamp
+
+ # Add here commands to clean up after the build process.
+ $(MAKE) clean
+
+ dh_clean
+
+install: build
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ dh_installdirs
+
+ # Add here commands to install the package into debian/$(APPNAME).
+ $(MAKE) INSTALL_ROOT="$(CURDIR)"/debian/$(APPNAME) install
+
+
+# Build architecture-independent files here.
+binary-indep: build install
+# We have nothing to do by default.
+
+# Build architecture-dependent files here.
+binary-arch: build install
+ dh_testdir
+ dh_testroot
+ dh_installchangelogs
+ dh_installdocs
+ dh_installexamples
+# dh_install
+# dh_installmenu
+# dh_installdebconf
+# dh_installlogrotate
+# dh_installemacsen
+# dh_installpam
+# dh_installmime
+# dh_python
+# dh_installinit
+# dh_installcron
+# dh_installinfo
+ dh_installman
+ dh_link
+ # dh_strip
+ dh_compress
+ dh_fixperms
+# dh_perl
+ dh_makeshlibs
+ dh_installdeb
+ dh_shlibdeps
+ dh_gencontrol
+ dh_md5sums
+ dh_builddeb
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary install configure